Back to overview
Resolved

Dashboard Latency in US-WEST-2

Jul 1, 2026 at 4:14am UTC
Affected services
Hatchet API
cloud.onhatchet.run

Resolved
Jul 1, 2026 at 5:42am UTC

We have identified the source of the latency and have pushed initial configuration changes to mitigate. We will continue to monitor for degraded performance.

Created
Jul 1, 2026 at 4:14am UTC

We are investigating reports of elevated latency on our OLAP database, which powers parts of the Hatchet UI and some API requests.

The core database is not affected. Workflow execution and workloads are continuing to run normally.