Back to overview
Resolved

[us-west-2] Increased Latency on Dashboard and APIs

Jul 1, 2026 at 2:43pm UTC
Affected services
Hatchet API
hatchet.run
cloud.onhatchet.run

Resolved
Jul 1, 2026 at 3:50pm UTC

We're continuing to monitor the fix. We've been seeing significant recovery since about 35 minutes ago (15:15 UTC).

If you're seeing tasks that are stuck during execution, cancelling and replaying will likely get them moving again.

Updated
Jul 1, 2026 at 3:15pm UTC

We've applied a candidate fix and are seeing some services begin to recover, and are continuing to monitor

Updated
Jul 1, 2026 at 3:00pm UTC

We're continuing to monitor affected gRPC APIs as well. We're seeing some reports of StatusCode.UNAVAILABLE being returned to SDKs from the API

Created
Jul 1, 2026 at 2:43pm UTC

We're monitoring some degradation in performance on the Hatchet dashboard and REST APIs, and the scheduler, and are working on a fix.

We believe about 30% of tenants are affected