Back to overview
Degraded

us-west-2 increased latency

Jun 19, 2026 at 11:00pm UTC
Affected services
Hatchet API
cloud.onhatchet.run

Resolved
Jun 21, 2026 at 8:00pm UTC

We’re back! Hatchet Cloud region us-west-2 should be up and running. Thanks for bearing with us.

Created
Jun 19, 2026 at 11:00pm UTC

Hatchet's shared cloud (free, team, and scale plans) in us-west-2 experienced a partial outage between 6/19/26 23:07:00 UTC and 6/20 and 00:34:00 UTC caused by crashes on an internal queue. We were alerted and responded immediately, which brought the service online. Task processing (e.g. dispatching tasks to workers) was affected, but ingestion was not. You may see stuck DAGs, which likely will need to be cancelled and replayed or retriggered from scratch to reconcile.

We'll continue to update as we investiage the root cause of the message queue crash.